NSA-Chiffre Speck wird aus dem Linux-Kernel entfernt

Hier hatte ich vor der Linux-Kernel-Version 4.17 gewarnt. Warum? Darum:

Die Version 4.17 des Linux-Kernel unterstützt die Blockchiffre Speck, die ursprünglich von der NSA stammt …

Jetzt soll der NSA-Müll wieder aus dem Linux-Kernel entfernt werden. Wahrscheinlich wird aber erst Version 4.20 wieder NSA-Frei sein.